Scheduled Maintenance - Tableau Analytics - Reports
Scheduled for June 28, 2025 at 2:30 PM – June 27, 2025 at 2:50 PM
Affects
Tableau Analytics - Reports
In progress
June 28, 2025 at 2:30 PMIn progress
June 28, 2025 at 2:30 PMMaintenance is now in progress.
We appreciate your patience and understanding.
Completed
June 27, 2025 at 2:50 PMCompleted
June 27, 2025 at 2:50 PMMaintenance has completed successfully.