Clearinghouse Reporting Hub - AWS Outage - Possible Impact to Distributor Clearinghouse Reporting Applications – Incident details

All systems operational

AWS Outage - Possible Impact to Distributor Clearinghouse Reporting Applications

Resolved
Major outage
Started about 2 months agoLasted about 22 hours
Updates
  • Resolved
    Resolved

    AWS outage resolved on 10/20/25 @ 06:53pm Eastern.

  • Monitoring
    Monitoring

    AWS has implemented a fix and we are currently monitoring the result.

  • Identified
    Identified

    AWS is continuing to work on a fix for this.

  • Investigating
    Investigating

    We want to inform you about a reported AWS outage that may impact Distributor Clearinghouse Reporting applications. Our engineering team is actively monitoring the situation and working to assess any potential effects on our services.

    Our teams are in close communication with AWS and will provide updates as we learn more.

    We appreciate your patience and understanding.